summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2010-02-09 15:32:54 -0800
committerRuss Allbery <rra@stanford.edu>2010-02-09 15:32:54 -0800
commitccf1cd7efa90bdcbe834e0d4ca144289cca97fd7 (patch)
treea3f791ef91920da7a1857e2e95bab3ecdf9aa4a7 /configure.ac
parentce6c27ef04783e21baf44549ff9e361e0c0f148e (diff)
Update portability code to rra-c-util 3.0
Add replacements for mkstemp and setenv, since we now use them when obtaining credentials in the client. Fix the bool type with Sun Studio 12 on Solaris 10.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 78fecea..1b91ff0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,7 +37,7 @@ RRA_C_GNU_VAMACROS
AC_TYPE_LONG_LONG_INT
RRA_FUNC_SNPRINTF
AC_CHECK_FUNCS([setrlimit])
-AC_REPLACE_FUNCS([asprintf strlcat strlcpy])
+AC_REPLACE_FUNCS([asprintf mkstemp setenv strlcat strlcpy])
AC_ARG_WITH([wallet-server],
[AC_HELP_STRING([--with-wallet-server=HOST], [Default wallet server])],