aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2007-09-27 03:22:46 +0000
committerRuss Allbery <rra@stanford.edu>2007-09-27 03:22:46 +0000
commite0f6e1222ede4a7545ca995a8aacaae0b591cb9c (patch)
tree2af9d140d13ee321c6fdb81c4444ca2e0e93c4a3 /configure.ac
parent7ec47028dbfe6df70d4c07e9546ae1680cf4e91f (diff)
Initial cut at srvtab support in the wallet client. This still requires
additional work and cleanup, particularly support for the sync attribute.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 700970e..2a8361f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,6 +71,12 @@ AC_SUBST([AFS_LIBS])
AC_CHECK_HEADERS([kerberosIV/krb.h])
AC_CHECK_DECLS([ubik_Call], , , [#include <ubik.h>])
+save_LIBS=$LIBS
+LIBS=-lkrb5
+AC_CHECK_FUNCS([krb5_get_error_message \
+ krb5_free_error_message \
+ krb5_get_err_text])
+LIBS=$save_LIBS
AC_CONFIG_HEADER([config.h])
AC_CONFIG_FILES([Makefile perl/Makefile.PL])