aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2013-03-27 15:51:58 -0700
committerRuss Allbery <rra@stanford.edu>2013-03-27 15:51:58 -0700
commita357f87b9e5ee6863ad2011be7944e30e3c9e6cd (patch)
tree3a2ae55a68b3ec52a5af0714a652179100e4d7f3 /debian/rules
parent53a80013a68a86013500607e9bf95ed9b26e6a5e (diff)
Update to debhelper V9, enable hardening, parallel builds
* Update debhelper compatibility level to V9. - Enable all hardening build flags. - Enable parallel builds. Change-Id: I816acdcf5a204fddc909f78e3db39493e7c2321e
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 5 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 11d6e5e..a60a61f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,10 +1,13 @@
#!/usr/bin/make -f
+# Add hardening build flags.
+export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow,+pie
+
%:
- dh $@
+ dh $@ --parallel
override_dh_auto_configure:
- dh_auto_configure -- --enable-reduced-depends
+ dh_auto_configure --parallel -- --enable-reduced-depends
# We rebuild the perl directory Makefile to encode the correct installation
# paths, since otherwise it defaults to using the local site module path.