summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2007-12-01 05:33:07 +0000
committerRuss Allbery <rra@stanford.edu>2007-12-01 05:33:07 +0000
commit8bd76656ab5247ce1a5d88c50e9cf2cd61bf6c33 (patch)
treee4843be9fec2ff128a853bde937bb016c09b5e9c /debian/rules
parentf9ef1fd6d7050a8296b019372dcd24960379ce5f (diff)
We now have arch-independent packages.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules22
1 files changed, 18 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index c4ba574..145a7f1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -39,8 +39,6 @@ build-indep:
build-stamp: config.status
dh_testdir
$(MAKE)
- cd $(CURDIR)/perl && perl Makefile.PL INSTALLDIRS=vendor
- cd $(CURDIR)/perl && $(MAKE)
$(MAKE) check
touch build-stamp
@@ -55,12 +53,12 @@ install: build-stamp
dh_testdir
dh_testroot
dh_clean
+ cd $(CURDIR)/perl && perl Makefile.PL INSTALLDIRS=vendor
$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
dh_installdirs
dh_install --fail-missing
binary: binary-arch binary-indep
-binary-indep:
binary-arch: DH_OPTIONS=-a
binary-arch: install
@@ -72,7 +70,6 @@ binary-arch: install
dh_link
dh_strip
dh_compress
- dh_perl
dh_fixperms
dh_installdeb
dh_shlibdeps
@@ -80,5 +77,22 @@ binary-arch: install
dh_md5sums
dh_builddeb
+binary-indep: DH_OPTIONS=-i
+binary-indep: install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs NEWS
+ dh_installdocs -A README TODO
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_perl
+ dh_fixperms
+ dh_installdeb
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
.PHONY: build build-arch build-indep clean binary-arch binary-indep binary
.PHONY: install