aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorRuss Allbery <eagle@eyrie.org>2014-07-16 14:12:04 -0700
committerRuss Allbery <eagle@eyrie.org>2014-07-16 14:12:04 -0700
commitdec2d15242727cb2d7f138ead9969413a8b73351 (patch)
tree03c3c7f1d3d16e6904294e14e1588665d445c7de /debian/rules
parentaf3d499fc63f12fd13df495f704f05c8ce07751e (diff)
Adjust debian/rules for the new Module::Build Perl build system
Change-Id: I6cc0df81ab9507a6aceba772766c0a0588b2d750
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 5 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 0471054..ce5ad97 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,6 +3,10 @@
# Add hardening build flags.
export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow,+pie
+# The additional flags to pass to Build.PL, picked up by the upstream build
+# system.
+export WALLET_PERL_FLAGS := --installdirs vendor --create_packlist 0
+
# Enable some additional Perl tests.
export AUTOMATED_TESTING = 1
@@ -12,10 +16,8 @@ export AUTOMATED_TESTING = 1
override_dh_auto_configure:
dh_auto_configure --parallel -- --enable-reduced-depends
-# We rebuild the perl directory Makefile to encode the correct installation
-# paths, since otherwise it defaults to using the local site module path.
+# Install the remctl configuration as part of the build.
override_dh_auto_install:
- cd perl && perl Makefile.PL INSTALLDIRS=vendor
dh_auto_install
install -d debian/tmp/etc/remctl/acl
install -m 0644 config/keytab.acl debian/tmp/etc/remctl/acl/keytab