summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac2
-rw-r--r--tests/config/README19
-rw-r--r--tests/data/README33
3 files changed, 21 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index 4fc218b..e417a5e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -70,4 +70,6 @@ AC_CONFIG_FILES([tests/client/basic-t], [chmod +x tests/client/basic-t])
AC_CONFIG_FILES([tests/client/full-t], [chmod +x tests/client/full-t])
AC_CONFIG_FILES([tests/client/prompt-t], [chmod +x tests/client/prompt-t])
AC_CONFIG_FILES([tests/client/rekey-t], [chmod +x tests/client/rekey-t])
+AC_CONFIG_COMMANDS([tests/config],
+ [test -d tests/config || mkdir tests/config])
AC_OUTPUT
diff --git a/tests/config/README b/tests/config/README
index 2992a11..cedaccf 100644
--- a/tests/config/README
+++ b/tests/config/README
@@ -22,3 +22,22 @@ password
be configured in your system krb5.conf file or in DNS configuration
picked up by your Kerberos libraries and must be in the same realm as
the keytab above or have valid cross-realm trust to it.
+
+If you are building in a different directory tree than the source tree,
+don't put the files in this directory. Instead, after running configure,
+you will have an empty tests/config directory in your build tree. Put the
+keytab and principal files in that directory instead.
+
+If your krb5.conf file is not in /etc or /usr/local/etc, put a copy of
+your krb5.conf file in the tests/data directory. The tests need to
+generate a modified copy in order to test some behavior.
+
+-----
+
+Copyright 2013
+ The Board of Trustees of the Leland Stanford Junior University
+
+Copying and distribution of this file, with or without modification, are
+permitted in any medium without royalty provided the copyright notice and
+this notice are preserved. This file is offered as-is, without any
+warranty.
diff --git a/tests/data/README b/tests/data/README
deleted file mode 100644
index f5ebf07..0000000
--- a/tests/data/README
+++ /dev/null
@@ -1,33 +0,0 @@
-This directory contains data used by wallet's test suite. To enable tests
-that require GSS-API authentication and a working end-to-end Kerberos
-environment, create the K5 keytab that will be used for both the server
-and the client and put it in this directory as test.keytab. Then, create
-a file named test.principal and in it put the principal name corresponding
-to the key in the keytab on a single line ending with a newline.
-
-The presence of these two files will enable the tests that actually do
-GSS-API authentication.
-
-If your krb5.conf file is not in /etc or /usr/local/etc, put a copy of
-your krb5.conf file in this directory. The tests need to generate a
-modified copy in order to test some behavior.
-
-To enable tests of password prompting, create a file named test.password
-that contains two lines. The first line should be a test principal and
-the second line should be the password for that principal. The newline is
-not taken to be part of the password.
-
-To enable tests of kasetkey (assuming that you've configured wallet with
---with-afs), create a K4 srvtab with ADMIN access to an AFS kaserver and
-put it in test.srvtab. Then, put the fully-qualified K4 principal name
-corresponding to that keytab in test.admin. The realm used for AFS
-kaserver testing will be derived from the realm of that principal name.
-
-If you are building in a different directory tree than the source tree,
-don't put the files in this directory. Instead, after running configure,
-you will have an empty tests/data directory in your build tree. Put the
-test.keytab, test.principal, and krb5.conf (if necessary) files in that
-directory instead.
-
-Note that to successfully run much of the test suite, you will need to have
-remctld installed on the system running the tests.