aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 26cd6dc..aa13a00 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,9 @@
# See README for licensing terms.
AUTOMAKE_OPTIONS = foreign subdir-objects
-EXTRA_DIST = doc/design-acl doc/design-api doc/design-schema doc/notes
+EXTRA_DIST = doc/design-acl doc/design-api doc/design-schema doc/notes \
+ tests/TESTS tests/client/basic-t.in tests/data/README \
+ tests/data/cmd-fake tests/data/fake-keytab tests/data/wallet.conf
bin_PROGRAMS = client/wallet kasetkey/kasetkey
client_wallet_CPPFLAGS = @REMCTL_CPPFLAGS@
@@ -16,3 +18,13 @@ kasetkey_kasetkey_CPPFLAGS = @AFS_CPPFLAGS@
kasetkey_kasetkey_LDFLAGS = @AFS_LDFLAGS@
kasetkey_kasetkey_LDADD = -lkauth.krb -lprot -lubik -lauth -lrxkad -ldes \
-lrx -llwp -lcom_err -lafsutil -lsys
+
+warnings:
+ $(MAKE) CFLAGS='$(WARNINGS)'
+ $(MAKE) CFLAGS='$(WARNINGS)' $(check_PROGRAMS)
+
+# The bits below are for the test suite, not for the main package.
+check_PROGRAMS = tests/runtests
+
+check-local: $(check_PROGRAMS)
+ cd tests && ./runtests TESTS