summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am38
1 files changed, 27 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 7917afb..d86cf28 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,17 +6,19 @@
# See README for licensing terms.
AUTOMAKE_OPTIONS = foreign subdir-objects
-EXTRA_DIST = TODO docs/design docs/design-acl docs/design-api \
- docs/netdb-role-api docs/notes docs/setup kasetkey/kasetkey.pod \
- perl/Wallet/ACL.pm perl/Wallet/ACL/Base.pm perl/Wallet/ACL/Krb5.pm \
- perl/Wallet/Config.pm perl/Wallet/Object/Base.pm \
- perl/Wallet/Object/Keytab.pm perl/Wallet/Schema.pm \
- perl/Wallet/Server.pm perl/t/acl.t perl/t/pod.t \
- tests/TESTS tests/client/basic-t.in tests/data/README \
- tests/data/cmd-fake tests/data/fake-keytab tests/data/wallet.conf
+EXTRA_DIST = TODO client/wallet.pod docs/design docs/design-acl \
+ docs/design-api docs/netdb-role-api docs/notes docs/setup \
+ kasetkey/kasetkey.pod perl/Wallet/ACL.pm perl/Wallet/ACL/Base.pm \
+ perl/Wallet/ACL/Krb5.pm perl/Wallet/Config.pm \
+ perl/Wallet/Object/Base.pm perl/Wallet/Object/Keytab.pm \
+ perl/Wallet/Schema.pm perl/Wallet/Server.pm perl/t/acl.t \
+ perl/t/init.t perl/t/keytab.t perl/t/object.t perl/t/pod.t \
+ perl/t/schema.t perl/t/server.t perl/t/verifier.t tests/TESTS \
+ tests/client/basic-t.in tests/data/README tests/data/cmd-fake \
+ tests/data/fake-keytab tests/data/wallet.conf
bin_PROGRAMS = client/wallet
-sbin_PROGRAMS = kasetkey/kasetkey
+sbin_PROGRAMS = kasetkey/kasetkey server/keytab-backend server/wallet-backend
client_wallet_SOURCES = client/wallet.c system.h
client_wallet_CPPFLAGS = @REMCTL_CPPFLAGS@
client_wallet_LDFLAGS = @REMCTL_LDFLAGS@
@@ -25,12 +27,25 @@ kasetkey_kasetkey_CPPFLAGS = @AFS_CPPFLAGS@
kasetkey_kasetkey_LDFLAGS = @AFS_LDFLAGS@
kasetkey_kasetkey_LDADD = @AFS_LIBS@ -lkrb4
-dist_man_MANS = kasetkey/kasetkey.8
+dist_man_MANS = client/wallet.1 kasetkey/kasetkey.8 server/keytab-backend.8 \
+ server/wallet-backend.8
+
+$(srcdir)/client/wallet.1: $(srcdir)/client/wallet.pod
+ pod2man --release=$(VERSION) --center="Administrative Commands" \
+ --section=1 $(srcdir)/client/wallet.pod > $@
$(srcdir)/kasetkey/kasetkey.8: $(srcdir)/kasetkey/kasetkey.pod
pod2man --release=$(VERSION) --center="Administrative Commands" \
--section=8 $(srcdir)/kasetkey/kasetkey.pod > $@
+$(srcdir)/server/keytab-backend.8: $(srcdir)/server/keytab-backend.pod
+ pod2man --release=$(VERSION) --center="Administrative Commands" \
+ --section=8 $(srcdir)/server/keytab-backend.pod > $@
+
+$(srcdir)/server/wallet-backend.8: $(srcdir)/server/wallet-backend.pod
+ pod2man --release=$(VERSION) --center="Administrative Commands" \
+ --section=8 $(srcdir)/server/wallet-backend.pod > $@
+
# A set of flags for warnings. Add -O because gcc won't find some warnings
# without optimization turned on, and add -DDEBUG=1 so we'll also compile all
# debugging code and test it.
@@ -45,7 +60,8 @@ warnings:
# Remove some additional files.
DISTCLEANFILES = perl/Makefile
MAINTAINERCLEANFILES = Makefile.in aclocal.m4 config.h.in config.h.in~ \
- configure kasetkey/kasetkey.8
+ configure client/wallet.1 kasetkey/kasetkey.8 \
+ server/keytab-backend.8 server/wallet-backend.8
# Take appropriate actions in the Perl directory as well.
all-local: