aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 5 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 11d6e5e..a60a61f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,10 +1,13 @@
#!/usr/bin/make -f
+# Add hardening build flags.
+export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow,+pie
+
%:
- dh $@
+ dh $@ --parallel
override_dh_auto_configure:
- dh_auto_configure -- --enable-reduced-depends
+ dh_auto_configure --parallel -- --enable-reduced-depends
# We rebuild the perl directory Makefile to encode the correct installation
# paths, since otherwise it defaults to using the local site module path.