summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e920649
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- --enable-reduced-depends
+
+# We rebuild the perl directory Makefile to encode the correct installation
+# paths, since otherwise it defaults to using the local site module path.
+override_dh_auto_install:
+ cd perl && perl Makefile.PL INSTALLDIRS=vendor
+ dh_auto_install
+ install -d debian/tmp/etc/remctl/acl
+ install -m 0644 config/keytab.acl debian/tmp/etc/remctl/acl/keytab
+
+override_dh_installchangelogs:
+ dh_installchangelogs NEWS