summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules29
1 files changed, 29 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..a60a61f
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,29 @@
+#!/usr/bin/make -f
+
+# Add hardening build flags.
+export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow,+pie
+
+%:
+ dh $@ --parallel
+
+override_dh_auto_configure:
+ dh_auto_configure --parallel -- --enable-reduced-depends
+
+# We rebuild the perl directory Makefile to encode the correct installation
+# paths, since otherwise it defaults to using the local site module path.
+override_dh_auto_install:
+ cd perl && perl Makefile.PL INSTALLDIRS=vendor
+ dh_auto_install
+ install -d debian/tmp/etc/remctl/acl
+ install -m 0644 config/keytab.acl debian/tmp/etc/remctl/acl/keytab
+ install -m 0644 config/wallet-report.acl \
+ debian/tmp/etc/remctl/acl/wallet-report
+
+override_dh_installchangelogs:
+ dh_installchangelogs NEWS
+
+override_dh_compress:
+ dh_compress -X examples
+
+override_dh_builddeb:
+ dh_builddeb -- -Zxz