summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rw-r--r--debian/compat2
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules7
4 files changed, 10 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 786acc6..4fac676 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,9 @@ wallet (1.0-1) UNRELEASED; urgency=low
- New comments field for objects and wallet commands to set and
retrieve it.
* Switch to xz compression for the upstream and Debian tarballs.
+ * Update debhelper compatibility level to V9.
+ - Enable all hardening build flags.
+ - Enable parallel builds.
* Move single-debian-patch to local-options and patch-header to
local-patch-header so that they only apply to the packages I build and
NMUs get regular version-numbered patches.
diff --git a/debian/compat b/debian/compat
index 7f8f011..ec63514 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-7
+9
diff --git a/debian/control b/debian/control
index b4ede49..8b5be8b 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: wallet
Section: net
Priority: extra
Maintainer: Russ Allbery <rra@debian.org>
-Build-Depends: debhelper (>= 7.0.50~), libdatetime-format-sqlite-perl,
+Build-Depends: debhelper (>= 9), libdatetime-format-sqlite-perl,
libdbd-sqlite3-perl, libdbi-perl, libdbx-class-perl, libkrb5-dev,
libremctl-dev, libsql-translator-perl, libtest-pod-perl, perl
Standards-Version: 3.9.4
diff --git a/debian/rules b/debian/rules
index 11d6e5e..a60a61f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,10 +1,13 @@
#!/usr/bin/make -f
+# Add hardening build flags.
+export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow,+pie
+
%:
- dh $@
+ dh $@ --parallel
override_dh_auto_configure:
- dh_auto_configure -- --enable-reduced-depends
+ dh_auto_configure --parallel -- --enable-reduced-depends
# We rebuild the perl directory Makefile to encode the correct installation
# paths, since otherwise it defaults to using the local site module path.