summaryrefslogtreecommitdiff
path: root/perl/Wallet/Object/Keytab.pm
AgeCommit message (Collapse)Author
2007-09-19Drop the leading underscore for internal methods. I haven't been usingRuss Allbery
that convention elsewhere.
2007-09-18Implement the locked flag.Russ Allbery
2007-08-31Use a better method of setting the internal error that automaticallyRuss Allbery
adjusts for trailing newlines and exception detritus, saving duplicate code. Standardize the documentation of the error() method and document using this in child classes of the generic ACL and Object classes. Disable printing of errors during connect in Wallet::Server since we're going to throw our own exception.
2007-08-31Be considerably more robust in the face of configuration errors. CheckRuss Allbery
our configuration and die if it isn't correct. Catch all the exceptions thrown by the _kadmin method and do something with them. Print a warning and then rethrow the exception in the parent when running a non-existent kadmin binary rather than throwing an exception in the child, which doesn't close things down cleanly. Be robust against an undefined KEYTAB_FLAGS setting. Ensure KEYTAB_TMP is set. Also some minor doc improvements.
2007-08-31Fix some documentation issues around trace information and add more SEERuss Allbery
ALSO references.
2007-08-31Add documentation.Russ Allbery
2007-08-30Fix the valid principal check and fix assumptions about who qualifiesRuss Allbery
principals in all the kadmin functions. Pass the realm to the kadmin command. Parse ktadd errors properly. Call _kadmin_ktadd with the correct arguments.
2007-08-30Do not require (or allow) principals to be qualified with the realm.Russ Allbery
2007-08-30Clean up all exception output when storing it in the error variable toRuss Allbery
remove the " at line" stuff added by Perl and the newlines so that the errors stored in objects are consistent. Fix various bugs in the base object, including a few more type vs. name inversions and use of object instead of name. Allow owners to be specified as ACL names instead of IDs, and change the ID to a name in show. Add a new test suite for the base object implementation.
2007-08-30Fix all the interfaces so that objects are identified as type, name, notRuss Allbery
name, type, and fix the schema for the places where I'd renamed name to object for no good reason. I don't know what I was thinking originally.
2007-08-28Unlink the temporary keytab file after we've gotten the data out of it.Russ Allbery
2007-08-28Throw exceptions for failure of object new() and create() functionsRuss Allbery
rather than returning undef so that we can save the error message.
2007-08-28Rename Wallet::Object to Wallet::Object::Base and fix some syntax errorsRuss Allbery
introduced by recent changes.
2007-08-28Add the keytab object implementation. Add the skeleton of a configRuss Allbery
module which currently doesn't do anything useful except define some variables so that I can do syntax checking.