aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Quigley <tsimonq2@ubuntu.com>2018-02-27 22:34:48 -0600
committerSimon Quigley <tsimonq2@ubuntu.com>2018-02-27 22:34:48 -0600
commit09fcc751ef158898c315ebc9299a0fa3a722d914 (patch)
tree91116653d831ca5de92274277237ba2a42db3365 /CMakeLists.txt
parent11e616945340e87a1f567ab92e6dfac3068875b1 (diff)
New upstream version 0.5.1+git20180227
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5cd014d3..ab62cad6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,7 +12,8 @@ SET( CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake" )
include(GNUInstallDirs)
if(${CMAKE_BUILD_TYPE} MATCHES [Dd]ebug)
- set(HARDINFO_DEBUG 1)
+ set(HARDINFO_DEBUG 1)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fsanitize=address")
endif()
if(${CMAKE_HOST_SYSTEM_NAME} MATCHES "Linux")