aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLeandro Pereira <leandro@hardinfo.org>2020-05-03 10:10:32 -0700
committerLeandro Pereira <leandro@hardinfo.org>2020-05-03 10:10:32 -0700
commit142244445116202f3ae99e64a271e7e53bfc7a54 (patch)
treeb659c660883a71cded83783c682d79115623dbf2 /CMakeLists.txt
parent62a13496e528d9c8ac552b85deb1a28a057b71e3 (diff)
Disable warnings about deprecated functions
Until we port this to GTK4 or something, we'll have to live with those.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3b9af705..acfdfeb0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,6 +71,7 @@ message(STATUS "LOCALEDIR = ${CMAKE_INSTALL_PREFIX}/share/locale")
message(STATUS "Building HardInfo for architecture: ${HARDINFO_OS}-${HARDINFO_ARCH}")
add_definitions("-std=gnu89")
+add_definitions("-Wno-deprecated-declarations")
add_subdirectory(po)