aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBurt P <pburt0@gmail.com>2019-06-26 22:58:57 -0500
committerLeandro A. F. Pereira <leandro@hardinfo.org>2019-06-28 07:04:04 -0700
commit91af75547e7d494a82f8af8d17b4b9acb0af938d (patch)
tree79937af68b1b37d88bf26dc5865c3aaf15e1c11b /CMakeLists.txt
parent495481a4f2c9b21acb7bcecd793b4b6e9078399a (diff)
Combine Memory DMI and Memory SPD into "Memory Devices"
Combines the information from DMI and SPD into a single Memory Devices section. Signed-off-by: Burt P <pburt0@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 67cb03c7..39acca1c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -155,7 +155,7 @@ set(MODULE_devices_SOURCES
modules/devices/printers.c
modules/devices/resources.c
modules/devices/sensors.c
- modules/devices/spd-decode.c
+# modules/devices/spd-decode2.c
modules/devices/storage.c
modules/devices/usb.c
)
@@ -201,8 +201,9 @@ set_source_files_properties(
set_source_files_properties(
modules/devices/dmi_memory.c
+# modules/devices/spd-decode2.c
PROPERTIES
- COMPILE_FLAGS "-std=c99"
+ COMPILE_FLAGS "-std=c99 -Wno-deprecated-declarations"
)
foreach (_module ${HARDINFO_MODULES})