aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBurt P <pburt0@gmail.com>2018-03-17 15:48:47 -0500
committerLeandro A. F. Pereira <leandro@hardinfo.org>2018-04-24 07:43:43 -0700
commitdffc0b9dd005015f5df36448b1f2952493f5fc1e (patch)
tree8d8b21ecd24d33e62f69c3f2c1db8952073b3887 /CMakeLists.txt
parent7bec02cb303c7fc096cdb91d5ef5d9323d728a37 (diff)
[new] pci_util: functions and data structures for pci information
Based on usb_util. Only current method is via lspci, but framework exists to add other methods. Signed-off-by: Burt P <pburt0@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bc480146..628583b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -215,6 +215,7 @@ endif()
if (HARDINFO_GTK3)
add_executable(hardinfo
hardinfo/usb_util.c
+ hardinfo/pci_util.c
hardinfo/binreloc.c
hardinfo/expr.c
hardinfo/hardinfo.c
@@ -244,6 +245,7 @@ target_link_libraries(hardinfo
else()
add_executable(hardinfo
hardinfo/usb_util.c
+ hardinfo/pci_util.c
hardinfo/binreloc.c
hardinfo/expr.c
hardinfo/hardinfo.c