aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBurt P <pburt0@gmail.com>2017-08-16 18:06:02 -0500
committerLeandro A. F. Pereira <leandro@hardinfo.org>2017-08-27 08:21:05 -0700
commited11c87c2cc56fe40f6d4503cf0cc56e7ed841f7 (patch)
treed12a969685fc9d695a4e85d3ee9e2129e0ed7615 /CMakeLists.txt
parentd9b1aa271b47c0a960a3112f6bbd9077222faa98 (diff)
Create dmi_util.c and move *_util.c to hardinfo/
These stand alone interfaces and are used across modules, so just make them available to any module by default. Signed-off-by: Burt P <pburt0@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d4c60fec..5cd014d3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -137,13 +137,11 @@ set(MODULE_computer_SOURCES
)
set(MODULE_devices_SOURCES
modules/devices.c
- modules/devices/cpu_util.c
modules/devices/${HARDINFO_ARCH}/processor.c
modules/devices/battery.c
modules/devices/devmemory.c
modules/devices/dmi.c
modules/devices/devicetree.c
- modules/devices/devicetree/dt_util.c
modules/devices/inputdevices.c
modules/devices/pci.c
modules/devices/printers.c
@@ -222,6 +220,9 @@ add_executable(hardinfo
hardinfo/util.c
hardinfo/vendor.c
hardinfo/info.c
+ hardinfo/cpu_util.c
+ hardinfo/dmi_util.c
+ hardinfo/dt_util.c
shell/callbacks.c
shell/iconcache.c
shell/menu.c
@@ -247,6 +248,9 @@ add_executable(hardinfo
hardinfo/util.c
hardinfo/vendor.c
hardinfo/info.c
+ hardinfo/cpu_util.c
+ hardinfo/dmi_util.c
+ hardinfo/dt_util.c
shell/callbacks.c
shell/iconcache.c
shell/menu.c