aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/control3
-rwxr-xr-xdebian/rules101
3 files changed, 5 insertions, 100 deletions
diff --git a/debian/changelog b/debian/changelog
index 72bf3c6b..5f00f01a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,7 @@ hardinfo (0.5.1+git20170605-1) UNRELEASED; urgency=medium
* Add source/format file to make the package use quilt.
* Update to latest Git snapshot to fix a few issues and modernize it a bit,
as upstream hasn't tagged a new version since 2009.
+ * Rewrite and modernize debian/rules, make it build with cmake.
-- Simon Quigley <tsimonq2@ubuntu.com> Sun, 18 Jun 2017 22:25:05 -0500
diff --git a/debian/control b/debian/control
index e41fe09f..78d3ed65 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,8 @@ Source: hardinfo
Section: x11
Priority: optional
Maintainer: Simon Quigley <tsimonq2@ubuntu.com>
-Build-Depends: debhelper (>= 10),
+Build-Depends: cmake,
+ debhelper (>= 10),
libffi-dev,
libgtk2.0-dev,
liblzma-dev,
diff --git a/debian/rules b/debian/rules
index 0aa70f67..f3542e38 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,102 +1,5 @@
#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-
-
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_PROGRAM += -s
-endif
-
-configure: configure-stamp
-configure-stamp:
- dh_testdir
- ./configure
-
- touch configure-stamp
-
-
-build: build-stamp
-
-build-stamp: configure-stamp
- dh_testdir
-
- $(MAKE)
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp
-
- # Add here commands to clean up after the build process.
- [ ! -f Makefile ] || $(MAKE) clean
- rm -f arch/this
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- # Add here commands to install the package into debian/hardinfo.
- $(MAKE) install DESTDIR=$(CURDIR)/debian/hardinfo
- install -d `pwd`/debian/hardinfo/usr/share/pixmaps
- install -m 644 debian/hardinfo.xpm \
- `pwd`/debian/hardinfo/usr/share/pixmaps
- install -d `pwd`/debian/hardinfo/usr/share/applications
- install -m 644 debian/hardinfo.desktop \
- `pwd`/debian/hardinfo/usr/share/applications
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- #dh_installchangelogs ChangeLog
- dh_installchangelogs
- dh_installdocs
-# dh_installexamples
- dh_install
- dh_installmenu
-# dh_desktop
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_installinit
-# dh_installcron
-# dh_installinfo
- dh_installman debian/hardinfo.1
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
-# dh_perl
-# dh_python
-# dh_makeshlibs
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+%:
+ dh ${@} --buildsystem cmake