aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRuss Allbery <eagle@eyrie.org>2020-05-17 20:21:59 -0700
committerRuss Allbery <eagle@eyrie.org>2020-05-17 20:21:59 -0700
commit108233784827d54361c99c67eaee9e668010b3c3 (patch)
tree329ad2e791fb27ecc037259c16b922be03e977d0 /Makefile.am
parent201ac5003d4fba8b15dbb64628782970bd3422fd (diff)
Reformat all C code with clang-format-10
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ba7b1be..d5e46a8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
# Automake makefile for wallet.
#
# Written by Russ Allbery <eagle@eyrie.org>
-# Copyright 2016, 2018 Russ Allbery <eagle@eyrie.org>
+# Copyright 2016, 2018, 2020 Russ Allbery <eagle@eyrie.org>
# Copyright 2006-2008, 2010, 2013-2014
# The Board of Trustees of the Leland Stanford Junior University
#
@@ -320,3 +320,9 @@ check-cppcheck:
# uninstall from Perl.
distuninstallcheck:
@:
+
+# Used by maintainers to reformat all source code using clang-format and
+# excluding some files.
+reformat:
+ find . -name '*.[ch]' \! -name snprintf.c \! -name krb5-profile.c \
+ -print | xargs clang-format-10 -style=file -i