aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2010-02-09 13:17:12 -0800
committerRuss Allbery <rra@stanford.edu>2010-02-09 13:17:12 -0800
commit2ecd8da6a7eaab79a9b8d0a5a59d91fc377d9b95 (patch)
tree01d46660a13779271f4b9b9534c36f7df821eab0 /Makefile.am
parentb037770195ef0bd98d6655a65873b25d90e36032 (diff)
Remove the kasetkey client for setting keys in an AFS kaserver
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 5 insertions, 19 deletions
diff --git a/Makefile.am b/Makefile.am
index 1465a9b..b647349 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,8 +34,7 @@ EXTRA_DIST = LICENSE autogen client/wallet.pod config/allow-extract \
config/keytab config/keytab.acl config/wallet docs/design \
contrib/README contrib/wallet-report contrib/wallet-report.8 \
docs/design-acl docs/design-api docs/netdb-role-api docs/notes \
- docs/setup examples/stanford.conf kasetkey/README \
- kasetkey/kasetkey.pod $(PERL_FILES) $(TEST_FILES)
+ docs/setup examples/stanford.conf $(PERL_FILES) $(TEST_FILES)
noinst_LIBRARIES = portable/libportable.a util/libutil.a
portable_libportable_a_SOURCES = portable/dummy.c portable/macros.h \
@@ -58,15 +57,6 @@ client_wallet_LDADD = util/libutil.a portable/libportable.a $(REMCTL_LIBS) \
dist_man_MANS = client/wallet.1 server/keytab-backend.8 \
server/wallet-admin.8 server/wallet-backend.8
-if AFS
-sbin_PROGRAMS = kasetkey/kasetkey
-kasetkey_kasetkey_CPPFLAGS = $(AFS_CPPFLAGS) $(KRB4_CPPFLAGS)
-kasetkey_kasetkey_LDFLAGS = $(AFS_LDFLAGS) $(KRB4_LDFLAGS)
-kasetkey_kasetkey_LDADD = util/libutil.a portable/libportable.a $(AFS_LIBS) \
- $(KRB4_LIBS)
-dist_man_MANS += kasetkey/kasetkey.8
-endif
-
$(srcdir)/client/wallet.1: $(srcdir)/client/wallet.pod
pod2man --release=$(VERSION) --center="Administrative Commands" \
--section=1 $(srcdir)/client/wallet.pod > $@
@@ -75,10 +65,6 @@ $(srcdir)/contrib/wallet-report.8: $(srcdir)/contrib/wallet-report
pod2man --release=$(VERSION) --center="Administrative Commands" \
--section=8 $(srcdir)/contrib/wallet-report > $@
-$(srcdir)/kasetkey/kasetkey.8: $(srcdir)/kasetkey/kasetkey.pod
- pod2man --release=$(VERSION) --center="Administrative Commands" \
- --section=8 $(srcdir)/kasetkey/kasetkey.pod > $@
-
$(srcdir)/server/keytab-backend.8: $(srcdir)/server/keytab-backend
pod2man --release=$(VERSION) --center="Administrative Commands" \
--section=8 $(srcdir)/server/keytab-backend > $@
@@ -104,10 +90,10 @@ warnings:
# Remove some additional files.
DISTCLEANFILES = perl/Makefile
-MAINTAINERCLEANFILES = Makefile.in aclocal.m4 config.h.in config.h.in~ \
- configure client/wallet.1 kasetkey/kasetkey.8 \
- server/keytab-backend.8 server/wallet-backend.8 tools/compile \
- tools/depcomp tools/install-sh tools/missing
+MAINTAINERCLEANFILES = Makefile.in aclocal.m4 config.h.in config.h.in~ \
+ configure client/wallet.1 server/keytab-backend.8 \
+ server/wallet-backend.8 tools/compile tools/depcomp tools/install-sh \
+ tools/missing
# Take appropriate actions in the Perl directory as well. We don't want to
# always build the Perl directory in all-local, since otherwise Automake does