aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2010-08-25 16:03:30 -0700
committerRuss Allbery <rra@stanford.edu>2010-08-25 16:03:30 -0700
commitb374f653006683e1be43556cdff2e050ce04d918 (patch)
tree897ea181b70b9b8eed88af9b8597bd22d090d167 /Makefile.am
parent468ded4c2fae05a815bef91bdcb17d52f9cdcb2b (diff)
Add additional gcc warnings
Add -Wformat=2 -Winit-self -Wswitch-enum -Wdeclaration-after-statement -Wshadow to the set of gcc warnings. Stop passing -DDEBUG=1 since I no longer use that define anywhere. Change -W to -Wextra since I'm requiring a fairly new GCC anyway.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index af5f25f..ae7a36d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -78,9 +78,14 @@ dist_man_MANS = client/wallet.1 client/wallet-rekey.1 server/keytab-backend.8 \
server/wallet-admin.8 server/wallet-backend.8 server/wallet-report.8
# A set of flags for warnings. Add -O because gcc won't find some warnings
-# without optimization turned on, and add -DDEBUG=1 so we'll also compile all
-# debugging code and test it.
-WARNINGS = -g -O -DDEBUG=1 -Wall -W -Wendif-labels -Wpointer-arith \
+# without optimization turned on. Desirable warnings that can't be turned
+# on due to other problems:
+#
+# -Wconversion http://bugs.debian.org/488884 (htons warnings)
+#
+# Last checked against gcc 4.4 (2010-08-15).
+WARNINGS = -g -O -Wall -Wextra -Wendif-labels -Wformat=2 -Winit-self \
+ -Wswitch-enum -Wdeclaration-after-statement -Wshadow -Wpointer-arith \
-Wbad-function-cast -Wwrite-strings -Wstrict-prototypes \
-Wmissing-prototypes -Wnested-externs -Werror