aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRuss Allbery <eagle@eyrie.org>2018-05-27 22:09:27 -0700
committerRuss Allbery <eagle@eyrie.org>2018-05-27 22:09:27 -0700
commitb719ab5395b7b7aff88f01cea86c1c02f444ed00 (patch)
tree4b3356098b1ce6feb403cce6554b1cc4b158d54c /Makefile.am
parentcb5d14ab90abb9ba0a6f705176121534d92461b3 (diff)
Add cppcheck testing target
No problems found, so nothing to fix.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index eb9ba7e..66193fe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -307,6 +307,12 @@ check-local: $(check_PROGRAMS)
@echo ''
cd perl && ./Build test
+# Used by maintainers to check the source code with cppcheck.
+check-cppcheck:
+ cd $(abs_top_srcdir) && cppcheck -q --error-exitcode=2 \
+ --suppressions-list=tests/data/cppcheck.supp \
+ --enable=warning,performance,portability,style .
+
# Alas, we have to disable this check because there's no way to do an
# uninstall from Perl.
distuninstallcheck: