aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2006-08-17 00:48:04 +0000
committerRuss Allbery <rra@stanford.edu>2006-08-17 00:48:04 +0000
commit774de98a472fc25bb8162057e1ae88603d28cfd4 (patch)
tree0105175ce0c1f628c087d8f546061e76385a2834 /configure.ac
parent6f79b22ae2db9b9114a8300a9710e21f9068e121 (diff)
Import gen_srvtab as kasetkey and add the basic build framework.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 36 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..05f0298
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,36 @@
+dnl Process this file with Autoconf to produce a configure script.
+dnl $Id$
+dnl
+dnl Written by Russ Allbery <rra@stanford.edu>
+dnl Copyright 2006 Board of Trustees, Leland Stanford Jr. University
+dnl
+dnl See README for licensing terms.
+
+AC_REVISION($Revision$)
+AC_PREREQ(2.57)
+AC_INIT([wallet], [1.0], [rra@stanford.edu])
+AC_CONFIG_AUX_DIR([tools])
+AM_INIT_AUTOMAKE
+AM_MAINTAINER_MODE
+
+AFS_CPPFLAGS=
+AFS_LDFLAGS=
+AC_ARG_WITH([afs],
+ AC_HELP_STRING([--with-afs=DIR],
+ [Prefix for AFS headers and libraries (for kasetkey)]),
+ [if test x"$withval" != xno ; then
+ AFS_CPPFLAGS="-I${withval}/include"
+ AFS_LDFLAGS="-L${withval}/lib"
+ fi])
+AC_SUBST([AFS_CPPFLAGS])
+AC_SUBST([AFS_LDFLAGS])
+
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_SEARCH_LIBS([gethostbyname], [nsl])
+AC_SEARCH_LIBS([socket], [socket], ,
+ [AC_CHECK_LIB([nsl], [socket],
+ [LIBS="-lnsl -lsocket $LIBS"], , [-lsocket])])
+
+AC_CONFIG_HEADER([config.h])
+AC_OUTPUT([Makefile])