aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2010-02-09 15:21:12 -0800
committerRuss Allbery <rra@stanford.edu>2010-02-09 15:21:12 -0800
commit838a73223d19e64a6556047791006f068b779307 (patch)
tree11daa49dbf0abf7ee167860ec6bae0dfa71633a3 /configure.ac
parent3b7b000d2d2423a578c0ddfa63773764417aec9e (diff)
Update the Autoconf code to rra-c-util 3.0
* Sanity-check the results of krb5-config before proceeding. * Fall back on manual probing if krb5-config results don't work. * Add --with-krb5-include and --with-krb5-lib configure options. * Add --with-remctl-include and --with-remctl-lib configure options. * Add --with-gssapi-include and --with-gssapi-lib configure options. * Don't break if the user clobbers CPPFLAGS at build time. * Suppress error output from krb5-config probes. * Prefer KRB5_CONFIG over a path constructed from --with-*. * Update GSS-API probes for Solaris 10's native implementation. * Change AC_TRY_* to AC_*_IFELSE as recommended by Autoconf. Also strip out more outdated AFS kaserver instructions from README.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 16 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 8d00229..78fecea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,32 +1,40 @@
-dnl Process this file with Autoconf to produce a configure script.
+dnl Autoconf configuration for wallet.
dnl
dnl Written by Russ Allbery <rra@stanford.edu>
-dnl Copyright 2006, 2007, 2008
+dnl Copyright 2006, 2007, 2008, 2010
dnl Board of Trustees, Leland Stanford Jr. University
dnl
dnl See LICENSE for licensing terms.
-AC_REVISION([$Revision$])
-AC_PREREQ([2.61])
+dnl We cannot use -Wall -Werror with AM_INIT_AUTOMAKE since we override
+dnl distuninstallcheck (not supported by Perl).
+AC_PREREQ([2.64])
AC_INIT([wallet], [0.9], [rra@stanford.edu])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_LIBOBJ_DIR([portable])
-AM_INIT_AUTOMAKE([1.10])
+AC_CONFIG_MACRO_DIR([m4])
+AM_INIT_AUTOMAKE([1.11 check-news])
AM_MAINTAINER_MODE
AC_PROG_CC
+AC_USE_SYSTEM_EXTENSIONS
AM_PROG_CC_C_O
AC_PROG_INSTALL
AC_PROG_RANLIB
-AC_AIX
-AC_GNU_SOURCE
+
+RRA_LIB_REMCTL
+RRA_LIB_KRB5
+RRA_LIB_KRB5_SWITCH
+AC_CHECK_FUNCS([krb5_kt_free_entry])
+AC_CHECK_MEMBERS([krb5_keytab_entry.keyblock], , , [#include <krb5.h>])
+RRA_LIB_KRB5_RESTORE
AC_HEADER_STDBOOL
AC_CHECK_HEADERS([sys/bitypes.h syslog.h])
AC_CHECK_DECLS([snprintf, vsnprintf])
RRA_C_C99_VAMACROS
RRA_C_GNU_VAMACROS
-AC_CHECK_TYPES([long long])
+AC_TYPE_LONG_LONG_INT
RRA_FUNC_SNPRINTF
AC_CHECK_FUNCS([setrlimit])
AC_REPLACE_FUNCS([asprintf strlcat strlcpy])
@@ -43,13 +51,6 @@ AC_ARG_WITH([wallet-port],
[AC_DEFINE_UNQUOTED([WALLET_PORT], [$withval],
[Define to the default server port.])])])
-RRA_LIB_REMCTL
-RRA_LIB_KRB5
-RRA_LIB_KRB5_SWITCH
-AC_CHECK_FUNCS([krb5_kt_free_entry])
-AC_CHECK_MEMBERS([krb5_keytab_entry.keyblock], , , [#include <krb5.h>])
-RRA_LIB_KRB5_RESTORE
-
AC_ARG_VAR([REMCTLD], [Path to the remctld binary])
AC_PATH_PROG([REMCTLD], [remctld], , [$PATH:/usr/sbin:/usr/local/sbin])
AS_IF([test x"$REMCTLD" != x],