aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRuss Allbery <eagle@eyrie.org>2021-09-04 13:01:38 -0700
committerRuss Allbery <eagle@eyrie.org>2021-09-04 13:01:38 -0700
commita5f322a55242a68613862d125d7fd0125b1c88bb (patch)
tree1473f8f0e28cc36ba8f1f5abbac8a4ef2f81b0bf /configure.ac
parentacaa1794f08b0b8a42e9247f5186e00a888bd437 (diff)
Fix deprecation warnings for new Autoconf
wallet should now work properly with Autoconf 2.71. This required updating tests/docs/spdx-license-t from rra-c-util, which in turn bumped the minimum required Perl version for the test suite to 5.10. That's not yet reflected in the documentation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 80eeee1..b8f84f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
dnl Autoconf configuration for wallet.
dnl
dnl Written by Russ Allbery <eagle@eyrie.org>
-dnl Copyright 2014, 2016, 2018, 2020 Russ Allbery <eagle@eyrie.org>
+dnl Copyright 2014, 2016, 2018, 2020-2021 Russ Allbery <eagle@eyrie.org>
dnl Copyright 2006-2008, 2010, 2013-2014
dnl The Board of Trustees of the Leland Stanford Junior University
dnl
@@ -39,12 +39,12 @@ AC_PROG_MKDIR_P
dnl Allow modification of the default wallet port, and setting a default
dnl wallet server when none is defined in krb5.conf.
AC_ARG_WITH([wallet-server],
- [AC_HELP_STRING([--with-wallet-server=HOST], [Default wallet server])],
+ [AS_HELP_STRING([--with-wallet-server=HOST], [Default wallet server])],
[AS_IF([test x"$withval" != xno && test x"$withval" != xyes],
[AC_DEFINE_UNQUOTED([WALLET_SERVER], ["$withval"],
[Define to the default server host name.])])])
AC_ARG_WITH([wallet-port],
- [AC_HELP_STRING([--with-wallet-port=PORT],
+ [AS_HELP_STRING([--with-wallet-port=PORT],
[Default wallet server port])],
[AS_IF([test x"$withval" != xno && test x"$withval" != xyes],
[AC_DEFINE_UNQUOTED([WALLET_PORT], [$withval],
@@ -97,7 +97,7 @@ AS_IF([test x"$REMCTLD" != x],
[Define to the full path to remctld to run remctl tests.])])
dnl Output section.
-AC_CONFIG_HEADER([config.h])
+AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES([Makefile])
AC_CONFIG_FILES([tests/client/basic-t], [chmod +x tests/client/basic-t])
AC_CONFIG_FILES([tests/client/full-t], [chmod +x tests/client/full-t])