aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2007-10-08 22:30:27 +0000
committerRuss Allbery <rra@stanford.edu>2007-10-08 22:30:27 +0000
commite1d816c48a34f2c0e0fb0262a7ae9f9614ca82e8 (patch)
tree3c3951fb1089741b74756ae7cbbfdcb30e290029 /configure.ac
parent316c726120de2b53894bbeac2d110a7fc74c1dd3 (diff)
Add --with-wallet-server and --with-wallet-port.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b5b27e7..ccacc33 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,20 @@ AC_ARG_WITH([remctl],
AC_SUBST([REMCTL_CPPFLAGS])
AC_SUBST([REMCTL_LDFLAGS])
+AC_ARG_WITH([wallet-server],
+ AC_HELP_STRING([--with-wallet-server=HOST], [Default wallet server]),
+ [if test x"$withval" != xno ; then
+ AC_DEFINE_UNQUOTED([WALLET_SERVER], ["$withval"],
+ [Define to the default server host name.])
+ fi])
+AC_ARG_WITH([wallet-port],
+ AC_HELP_STRING([--with-wallet-port=PORT],
+ [Default wallet server port]),
+ [if test x"$withval" != xno ; then
+ AC_DEFINE_UNQUOTED([WALLET_PORT], [$withval],
+ [Define to the default server port.])
+ fi])
+
AC_ARG_VAR([REMCTLD], [Path to the remctld binary])
AC_PATH_PROG([REMCTLD], [remctld], , [$PATH:/usr/sbin:/usr/local/sbin])
if test x"$REMCTLD" != x ; then