aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRuss Allbery <rra@stanford.edu>2008-02-12 01:31:05 +0000
committerRuss Allbery <rra@stanford.edu>2008-02-12 01:31:05 +0000
commitfb06cf6028090d371a6ecdddba59ed2bed0ad465 (patch)
tree2f9a67a30b8fbe7954ffd54be1f8992a736625f8 /configure.ac
parent247366355b63b3f6804d591dde9d5b48895a8fdf (diff)
Initial pass at an end-to-end test suite.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e559b2d..3ef580a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,9 +60,11 @@ dnl Needed to get prototypes for functions like asprintf on Linux.
AC_DEFINE([_GNU_SOURCE], [1], [Define to 1 on Linux to get full prototypes.])
AC_CONFIG_HEADER([config.h])
-AC_CONFIG_FILES([Makefile perl/Makefile.PL])
+AC_CONFIG_FILES([Makefile perl/Makefile.PL tests/data/full.conf])
AC_CONFIG_FILES([tests/client/basic-t], [chmod +x tests/client/basic-t])
+AC_CONFIG_FILES([tests/client/full-t], [chmod +x tests/client/full-t])
AC_CONFIG_FILES([tests/client/pod-t], [chmod +x tests/client/pod-t])
+AC_CONFIG_FILES([tests/data/cmd-wrapper], [chmod +x tests/data/cmd-wrapper])
AC_CONFIG_FILES([tests/server/admin-t], [chmod +x tests/server/admin-t])
AC_CONFIG_FILES([tests/server/backend-t], [chmod +x tests/server/backend-t])
AC_CONFIG_FILES([tests/server/keytab-t], [chmod +x tests/server/keytab-t])