aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 6 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 1d2f446..009a3ba 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,6 +16,12 @@ export AUTOMATED_TESTING = 1
override_dh_auto_configure:
dh_auto_configure --parallel -- --enable-reduced-depends
+# Disable the strictness test, since precise doesn't have the dependencies.
+override_dh_auto_test:
+ mv perl/t/style/strict.t perl/t/style/strict.t-off
+ dh_auto_test --parallel
+ mv perl/t/style/strict.t-off perl/t/style/strict.t
+
# Install the remctl configuration as part of the build.
override_dh_auto_install:
dh_auto_install